We want to hear from you!Take our 2020 Community Survey!

Requeriments de l'Entorn de JavaScript

React 16 depèn dels tipus de col·lecció Map i Set. Si vols compatibilitat amb els navegadors i dispositius més antics que no poden proporcionar aquests productes de forma nativa (per exemple, IE < 11) o que tenen implementacions no compatibles (per exemple IE 11), considera incloure un polyfill global a la teva aplicació, com ara core-js.

Un entorn polyfilled de React 16 que faci servir core-js per fer-lo compatible amb els navegadors més antics es podria semblar a:

import 'core-js/es/map';
import 'core-js/es/set';

import React from 'react';
import ReactDOM from 'react-dom';

ReactDOM.render(
  <h1>Hello, world!</h1>,
  document.getElementById('root')
);

React també depèn de requestAnimationFrame (fins i tot en entorns de test). Pots fer servir el paquet raf per a apedaçar requestAnimationFrame:

import 'raf/polyfill';
Is this page useful?Edit this page